Investigating issue with secure.exely.uz
Incident Report for
System status
Resolved
We are currently investigating an issue affecting secure.exely.uz.
Users may experience slow loading of their Exely account.
Our team is actively working to identify the root cause.
Thank you for your patience.
Posted
Aug
19
,
2026
-
10:44
EEST
×
Subscribe to Incident
Subscribe to updates for
Investigating issue with secure.exely.uz
via . You'll receive .