StayStore - Incident resolved

Incident Report for System status

Update

We are continuing to investigate this issue.
Posted Jun 02, 2026 - 15:40 EEST

Investigating

The issue affecting StayStore has been resolved.

All systems are operating normally.

We apologize for the disruption.
Posted Mar 17, 2026 - 12:20 EET
This incident affects: Staystore.